Experience the difference of "Elite".

Quickbooks - Which online version?

Michele W
Feb 15, 2019 1:02 PM
Joined Sep, 2018 35 posts

To use Quickbooks, will the cheapest version $10 per month work? (now on sale for $5 all plans are 50% off) If not what version is required to integrate?

Chris Hynes
Feb 15, 2019 10:39 PM
OR Team Member Joined Oct, 2012 1353 posts

You can use any QuickBooks edition (Starter/Simple Start, Essentials, Plus, Premium, Advanced) with OwnerRez. Not sure if "freelancer" will work though, that one is a bit of an oddball.

The only limitation of the lower versions in relationship to OwnerRez is you can't use classes to dimensionalize your QB data and reports -- usually if you have multiple properties you'll set the property as a Class or Location on the invoice which will let you pull P&L's etc by property.

The higher versions allow that (I believe they call it "Run advanced reports" vs "basic"), the lower ones do not.

If you don't need that feature, then any edition will work.

Michele W
Feb 19, 2019 2:13 PM
Joined Sep, 2018 35 posts

UPDATE: Only the top tier version of online QB, $60 per month, will work with OR importation. I discovered this after spending a couple of hours getting all this set up on both sites. Live and learn. Reason being: it is the only version that supports classes and locations, which the OR interface uses to map your income and expenses to each property. Exception could be if you only have ONE location, the lowest "small business" version would probably work.

Sherene M
Feb 20, 2019 12:06 PM
Joined Jan, 2018 26 posts

Yikes, Thanks for the heads up Jim!

Paul W
Feb 20, 2019 9:06 PM
OR Team Member Joined Jun, 2009 710 posts

Just to clarify, OwnerRez will work perfectly fine with lower/cheap tiers of QuickBooks and your invoice/payments will flow across fine. Jim is talking specifically about the location/class tracking. Not all users use that. If you do, then you'll need the more expensive versions . Same with multi-currency support - that is only supported in expensive version. But we do support all versions even the cheap ones.