One day shows 0 rate

Replies: 5 - Pages: 1 - Last Reply: Oct 11, 2016 5:12 PM by: Sam Westcott
BlueMtnCabins
Registered: 6/6/16
One day shows 0 rate

I have 'late summer" period defined as Aug 20 - 30, 2017. Aug 31st is beginning of "premier" (holiday) weekend.
I have weekly and weekday night/weekend night prices set for "late summer"
When i test prices, what is happening is this:
1. if rental period starts on Aug 30, the night of Aug 30 shows 0 price; the subsequent nights have correct price.
2. if the night of Aug 30 falls in the middle of rental period (ex: Aug 28 - Aug 31), the night of Aug 30 is not a 0 price.
3. if the period ends on Aug 30, (ex: Aug 24 - Aug 30), Aug 30 price is 0 again.
happens on both properties. I checked the rate periods - periods do not overlap. My next period starts on Aug 31.
I have tested everything, cannot think what the reason is. Thanks in advance for any help.

Sam Westcott
Registered: 12/19/09
Re: One day shows 0 rate

@u0999: We are looking into this. I did reproduce your issue and I notice that there is a "Weekday Night" that should be covering that Wednesday (August 30, 2017). Probably a small edge case that may be slipping through the cracks after our recent big rate engine update.

BlueMtnCabins
Registered: 6/6/16
Re: One day shows 0 rate

Sam Westcott said:

@u0999: We are looking into this. I did reproduce your issue and I notice that there is a "Weekday Night" that should be covering that Wednesday (August 30, 2017). Probably a small edge case that may be slipping through the cracks after our recent big rate engine update.

Thanks,

Another question - I want to add a specific discount but NOT on stays that include certain holiday periods. But I noticed that if the stay dates are split between 2 periods (one period that is eligible for discount and another period is not), the discount still shows up. Even though I do not have this discount ticked on the holiday period (it is ticked on adjacent non-holiday period). I tried to change priorities but that did not help.

example:
I have Cleaning fee discount on weekly stays during "Standard" , "Late Summer" and other periods. I do NOT want to give discount if stay includes "Labor day" period (Aug 31 - Sep 4). I have discount unticked on "Labor day" period, BUT if I run a quote for Aug 28 ("Late summer") through Sep 4 ("labor day"), the discount is still there. Am I dong something wrong? Thanks

Sam Westcott
Registered: 12/19/09
Re: One day shows 0 rate

Awesome catch on the bug, u0999! Found it and we're dong a hotfix for that as I speak. It had nothing to do with seasons. It had to do with the way Weekday Night was being determined. Found a small edge case there. Great find!

Sam Westcott
Registered: 12/19/09
Re: One day shows 0 rate

This is now fixed. Try those same dates again in the Rate Tester and it should work now. Looking into that discount issue...

Pages: 1